Probleem:
Bij het opstarten van AutoCAD i.c.m. Techline komt een foutmelding op:
Er is een fout opgetreden bij de verbinding naar de database. Unable to open connection with database. The Database Provider is 'System.Data.SqlClient'. The Database connection is 'Server=(local)\sqlexpress;integrated Security=true;AttachDbFilename=C:\Users\<gebruikersnaam>\AppData\Roaming\Cadac Group\Techline\UserContent\NPT_USER.MDF;User Instance=True'. Techline 4.4.x.x
Hierna kan er geen gebruik gemaakt worden van de Usersymbolen binnen Techline.
Oorzaak:
De oorzaak is een rechten conflict. De gebruiker heeft onvoldoende rechten om een 'user instance' van de database aan te mogen maken en te gebruiken.
Oplossing:
De beste werkwijze om deze melding te voorkomen is volgende:
- Download en installeer de SQL Sever Management Studio (SSMS) versie 17.9.1 vanaf deze website: https://go.microsoft.com/fwlink/?linkid=2043154&clcid=0x409
- Start SQL Sever Management Studio (SSMS)
- Maak verbinding met de SQL Server <computernaam>\SQLEXPRESS
- selecteer de regel 'Databases' (Deze wordt geopent)
- Geef een rechtermuisklik op 'Databases', en kies 'Restore databases'
- Activeer de functie 'Device' en klik op de knop [ ... ] (Browse)
Het scherm 'Select Backup devices' verschijnt - Klik op [ Add ]
Browse naar de map: C:\Program Files\Cadac Group\Techline\Database\
- Selecteer hier de NPT_USER.bak
- Klik [ OK ]
- Klik [ OK ] in het 'Select Backup devices'
- Klik [ OK ] voor de melding 'Database 'NPT_USER' restored succesfully.'
- Klik [ OK ]
- Sluit SSMS.
- Klik [ Opties ]
- Kies 'Configuratie'
- Selecteerde regel 'Eigen Symbolen database'
- Wijzig de 'Connectiestring naar deze waarde:
- Server=(local)\sqlexpress;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=NPT_USER
- Klik [ Test Connectie ]
- Bij de melding 'Connectie OK', klik [ OK ]
- Klik [ Opslaan ]
- Klik [ Ja ]
- Klik [ Sluiten ]
Bij Cadac maken we onderscheid tussen Sales, Service & Support. Sales & Service vinden wij vanzelfsprekend. Wij helpen u met de aanschaf van uw product, dienst, training of expert en zorgen ervoor dat u probleemloos aan de slag kunt. Gratis en voor niets. U kunt zorgeloos met uw software starten, wij zorgen ervoor dat u het meeste uit uw software kunt halen.
Loopt u tegen technische softwareproblemen aan? Dan kunt u gebruik maken van Cadac Support. Door de juiste informatie in te dienen kunnen wij u zo snel mogelijk helpen