What should I do when Initializing does not work?
Problem:
When I click the initialize button nothing happens.
Cause:
You do not have write permissions to TheModus model Extender files in the %localAppData%.
This has to do with Windows 11.
Our development department is investigating this. Until then, you can use the solution below.
Solution:
- Open Windows Explorer and browse to C:\Users\[user]n\AppData\Local\Cadac Group\TheModus Model Extender
- Select the folders: Base Tables, Cache, Classification Templates, ExchangeDefinitions and ExchangeFiles.
- Copy these folders
- Go to C:\Users\[user]\Documents and create a new folder called TM Model Extender.
Paste the copied folders into this folder.
- In Revit, go to the 'TheModus Model Extender' tab.
- Open Settings -> Global Settings.
Click on the three dots behind Classification standard and browse to C:\Users\[user]\Documents\TM Model extender\Classification Templates
- Click Select folder
In the following notification: 'Same parent folder', click Ja. This also adjusts the other search paths.
- Restart Revit
Check if Initialize works again.
If you still receive an error about the write permissions of the Shared parameter file, please follow the next steps.
- In Revit go to Manage -> Shared parameters.
Check here the path where these shared parameters are stored.
Browse to this path in windows explorer.
Copy the shared parameters.txt file to the previously created folder: C:\Users\[user]\Documents\TM Model extender
- Check in the properties of this file whether 'read only' is unchecked.
- In Revit go to Manage -> shared parameters.
Click Browse and navigate to the new location of the shared parameters, C:\Users\[user]\Documents\TM Model extender.
The Initialize button in TheModus Model Extender should now work.