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What to do with error message "Failed to open document" in Revit?


Last modified on: 12 de octubre de 2023

Problem:

When linking BIM 360 based models into a project a message is shown that a license is no longer available ande the application (Revit) will be closed within 10 minutes:


"Your User license has expired and you are working within a grace period. There are 10 minutes remaining before the application will be Closed.
You will be prompted to save any modified files."


Cause:

The Desktop Connector data has become corrupt.

The Journal file will record lines similar to the following when trying to load the link:

' [Jrn.ModelOperation] Rvt.Attr.Scenario: ModelOpen COMMON.OS_VERSION:  Rvt.Attr.ModelVerEpisode: 00000000-0000-0000-0000-000000000000 -1 , Rvt.Attr.ModelPath: RVT[####################] Rvt.Attr.ModelSize: 0 Rvt.Attr.DetectDuration: -1 Rvt.Attr.Worksharing: UnknownWorksharingState Rvt.Attr.ModelState: InvalidOleStructure Rvt.Attr.DiskType: 
'C DD-Mmm-YYYY HH:MM:SS.SSS;   4:< Load exception "COleException", code=0x80030109: The docfile has been corrupted.
'C DD-Mmm-YYYY HH:MM:SS.SSS;   4:< COleServerDoc::ReportSaveLoadException
' 4:< TaskDialog "Failed to open document."
'CommonButtons : Close


Solutions:

Clear Cache

Use the instructions in the following article to clear the damaged cache file(s): How to clear the cache of the BIM 360 Desktop Connector.


Reinstall Desktop Connector

If removing the cached files does not clear the error, go through the following steps to uninstall/reinstall the Desktop Connector: 

  1. Uninstall the application via the Control Panel.
  2. Delete the following folders: 
    • C:\Users\%USERNAME%\AppData\Local\Autodesk\Desktop Connector
    • C:\Users\%USERNAME%\AppData\Local\Autodesk\Web Services\DesktopConnector
  3. Delete the following registry keys (be advised that it is recommend to first export out or 'save' a copy of the current registry before deleting or modifying any keys):
    • HKEY_CURRENT_USER\SOFTWARE\Autodesk\Autodesk Desktop Connector
    • HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Desktop Connector
  4. Restart the computer.
  5. Reinstall the application.


More Troubleshooting

If journal entries like the ones listed above are not showing up on your system, check if one of the following articles apply:

Journal Entries
Article
Collaborate.dll is not signed and cannot be an internal addin"Failed to open document" when opening a cloud workshared model in Revit
Load exception "COleException", code=0x80030109: The docfile has been corrupted."Failed to open document" error when linking cloud model via Desktop Connector to a Revit model


If the articles above don't apply, check this link for more articles on this error: "Failed to open document"


Source: