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Autodesk 2020 software gives the error message: License checkout timed out. What do you want to do?


Zuletzt geändert am: 18 de julio de 2019

Issue:

When starting Autodesk software version 2020, the following message appears after several seconds, and the program must close. 

Product License - Out of Time

License checkout timed out. What do you want to do?

Save Drawings and Quit

Quit without Saving

AutoCAD will be closed down.

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Causes:

There are multiple potential causes for this behavior:

  • Autodesk Desktop Licensing Service is not running.
  • Corrupted C:\ProgramData\Autodesk\AdskLicensingService\AdskLicensingService.sds file.


Solution:

Try the following options one by one, testing the software after each attempt:

Option 1. Verify that the Autodesk Desktop Licensing Service is running

This new licensing service is required for Autodesk 2020 software versions.

  1. Sign in to the Autodesk desktop app and install the hotfix Autodesk Licensing Service v9.0.3.46 - April 2019.
  2. Restart the computer.
  3. Click the Start menu (or right-click Start on Windows 10) and choose Run.
  4. In the Run box, type services.msc.
  5. In the Name column of the Services console window, find the Autodesk Desktop Licensing Service and check whether its status is Running.

Note: If it isn't running, right-click it and select Start.

  1. Right-click the service name and select Properties.
  2. In the Properties dialog box, use the drop-down menu to change Startup Type to Automatic (Delayed Start).
  3. Click Apply and OK.
  4. Start AutoCAD.

 

Option 2. The Autodesk Desktop Licensing Service is running, but the error persists

  1. Sign out of the Autodesk desktop app.
  2. Delete the %LOCALAPPDATA%\Autodesk\Web Services\LoginState.xml file.
  3. Open Windows Task Manager (type taskmgr in Windows Search and press Enter).
  4. Go to the Details tab and end the following processes, if they are running:
    • AutodeskDesktopApp.exe
    • AdAppMgrSvs.exe
    • AdskLicensingService.exe
  5. Navigate to C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.
  6. Run uninstall.exe as admin (right-click > Run As Administrator).
  7. Go to C:\ProgramData\Autodesk\ and delete the folder AdskLicensingService.
  8. Restart the computer.
  9. Temporarily disable User Account Control in Windows and any antivirus software.
  10. Go to the Autodesk 2020 product install folder and open \x86\AdskLicensing (for AutoCAD 2020, it is C:\Autodesk\AutoCAD_2020_English_win_64bit_dlm\x86\AdskLicensing). 
  11. Run AdskLicensing-installer.exe as admin (right-click > Run As Administrator). Wait for the install to complete.
  12. Install the latest updates for Autodesk Licensing Service, either from Autodesk desktop app or from Product Updates in Autodesk Account (see step 1 from Option 1).
  13. Click the Start menu and type CMD.
  14. At the Command prompt, right-click and choose Run As Administrator.
  15. At the Command prompt, run the following commands:
cd C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\helper\ 
AdskLicensingInstHelper register -pk 001L1 -pv 2020.0.0.F -cf C:\Autodesk\AutoCAD_2020_English_win_64bit_dlm\Setup\AutoCADConfig.Pit -el US

Note: The example uses "AutoCAD 2020 - English US" as an example. The --prod_key, --config_file and -el values vary according to the product. See Autodesk Licensing Installer Helper tool guide for more information.

  1. Run the software again and sign in if prompted.

 

Option 3. Reinstall the Autodesk Single Sign On Component

  1. Navigate to Control Panel > Uninstall a Program.
  2. Find the Autodesk Single Sign On Component and uninstall it.
  3. Navigate to the software installation media (for example, for AutoCAD it's C:\Autodesk\AutoCAD_2020_English_Win_64bit_dlm).
  4. Open the folder \x64\AdSSO.
  5. Run the AdSSO.msi file and let the installation complete.
  6. When finished, try to run AutoCAD.

 

Option 4. Check the firewall port of the Licensing Component

If a third-party firewall (such as ZoneAlarm) is active, make sure that localhost (127.0.0.1) is not blocked and that the port number for the Autodesk Desktop License Service is open. Follow these steps to test whether a port is blocked:

  1. In Notepad or another text editor, open the AdskLicensingService.data file from C:\ProgramData\Autodesk\AdskLicensingService.
  2. Note the IP address and port being used. For example: {"Addr":"127.0.0.1:54317","AutoPickFreePort": True}.
  3. Open a web browser and paste the IP/port value using http://. For example: http://127.0.0.1:54317.
  4. This message should appears: "The service is running and listening...", if this message doesn't appear:
    • The Autodesk Desktop License Service is not running. Run it from C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\AdskLicensingService.exe.
    • The localhost port is blocked. Check the firewall and unblock the port.

User-added image

 

Option 5. Verify permissions on Licensing Component folders

  1. Navigate to C:\ProgramData\Autodesk.
  2. Right-click AdskLicensingService > Properties > Security. 
    • Make sure that Users and LOCAL SERVICE have Full Control permissions assigned.
    • If not, click Edit to add them both and then select the Full Control checkbox.
  3. Repeat step 2 for the folder C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.
  4. Open Windows Services (in the Start menu, type services.msc and press Enter). 
  5. Find Autodesk Desktop Licensing Service. Right-click it and select Stop and then Start (or select Start if the service wasn't running).
  6. Open the software again and test it.

If none of the previous solutions work, see the following resources:

 

Source: https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Error-License-checkout-timed-out-What-do-you-want-to-do-in-AutoCAD-2020.html?v=2020