Skip to main content

Choose a country to view the content specific to your geographical location and language

autodesk-inventor-lt-2018-ico

Autodesk

Inventor LT 2018

The affordably priced version of Inventor enables you to create 3D models quickly and effectively. Inventor LT 2018 now also lets you create your own 3D PDF files.

Unfortunately, this product is no longer available
View recent versions of Inventor LT 2018 in our software overview or contact our service desk +44 208 282 60 16. Available Monday to Friday 08.30 to 17.00
Cadacstore support

Order the latest version

System requirements Inventor LT 2018

Inventor LT 2018 System requirements

Source: Autodesk

Operating System ¹

  • 64-bit Microsoft Windows 10
  • 64-bit Microsoft Windows 8.1 with Update KB2919355
  • 64-bit Microsoft Windows 7 SP1

CPU Type ²

  • Recommended: Intel Xeon E3 or Core i7 or equivalent, 3.0 GHz or greater
  • Minimum: Intel or AMD, 2 GHz or faster


Memory ³
6 GB RAM (12 GB is recommended).

Display Resolution
1280 x 1024 or higher.

Recommended scaling: 100%, 125%, 150% or 200%.

Notes:

  1. Autodesk® Inventor LT™ and Autodesk® Vault must both be the same language on a given computer. English versions of these applications will run on any language operating system. Other language versions of these applications will run on operating systems of that same language.
  2. Autodesk® Inventor LT™ is optimized to take advantage of the SSE2 extended instruction sets supported on Pentium 4, AMD Athlon 64, and AMD Opteron processors. Inventor LT will not install on computers that do not support SSE2. Several utilities are available on the Internet that report CPUID including supported instructions sets.
  3. Autodesk recommends settings which allow Microsoft Windows to manage virtual memory as needed. There should always be at least twice as much free hard disk space as system memory (RAM).
  4. DVD-ROM drive is not required if installing from USB or software download.
  5. The multimedia learning components of the Inventor Help system, such as the UI Video Tour, Command Reference, and Show Me animations, require Adobe Flash Player 10. If it is not already installed, you can download it from the Adobe website.

Order the latest version

Choose a region

Europe

World