Skip to main content

Workflows fail to start after Windows updates

Troubleshooting

Last modified on 22 January 2020

Description:

After installing Windows updates all Organice Workflows fail on start


The logging shows "

Validation error: <Error><CompilerError Line="-1"Column="-1" Text="Type System.CodeDom.CodeMethodInvokeExpressionis not marked as authorized in the application configuration file."/><CompilerError Line="-1" Column="-1"Text="Type System.CodeDom.CodePrimitiveExpression is not marked asauthorized in the application configuration file." /><CompilerErrorLine="-1" Column="-1" Text="Type System.CodeDom.CodeMethodInvokeExpressionis not marked as authorized in the application configuration file."/><CompilerError Line="-1" Column="-1"Text="Type System.CodeDom.CodePrimitiveExpression is not marked asauthorized in the application configuration file." /><CompilerErrorLine="0" Column="0" Text="Activity 'ID4' validationfailed: Property &quot;Condition&quot; has invalid value. Conditionexpression is invalid. The expression to the left of operator&quot;ValueEquality&quot; can not be null." /><CompilerErrorLine="0" Column="0" Text="Activity 'ID4' validation failed:Property &quot;Condition&quot; has invalid value. Condition expressionis invalid. The expression to the right of operator&quot;ValueEquality&quot; can not be null." /><CompilerErrorLine="0" Column="0" Text="Activity 'ID11' validationfailed: Property &quot;Condition&quot; has invalid value. Conditionexpression is invalid. The expression to the left of operator&quot;ValueEquality&quot; can not be null." /><CompilerErrorLine="0" Column="0" Text="Activity 'ID11' validationfailed: Property &quot;Condition&quot; has invalid value. Conditionexpression is invalid. The expression to the right of operator&quot;ValueEquality&quot; can not be null." /></Error>

 

TYPICAL SOLUTION

If you have been using Organice Process System SDK check SDKDocumentation for this Error.

If you haven't been using SDK try to reinstall Organice Process System,it could be needed to restart machine before. If problem is continuing contactOrganice."



Cause 

Installing ".NET security patches to address  CVE-218-8421" SharePoint workflows stop working.


For more information see:

https://support.microsoft.com/en-us/help/4465015/sharepoint-workflows-stop-after-cve-2018-8421-security-update



Solution

The solution is to explicitly add the necessary types to all web applications' web.config files.


For SharePoint 2013 and later versions

For SharePoint 2013 and later versions, add the following lines:

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeBinaryOperatorExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodePrimitiveExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeMethodInvokeExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeMethodReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeFieldReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeThisReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodePropertyReferenceExpression" Authorized="True" />


For SharePoint versions earlier than SharePoint 2013

For SharePoint versions earlier than 2013, add the following lines instead:

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeBinaryOperatorExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodePrimitiveExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeMethodInvokeExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeMethodReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeFieldReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodeThisReferenceExpression" Authorized="True" />

<authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" NameSpace="System.CodeDom" TypeName="CodePropertyReferenceExpression" Authorized="True" />




Bij Cadac maken we onderscheid tussen Sales, Service & Support. Sales & Service vinden wij vanzelfsprekend. Wij helpen u met de aanschaf van uw product, dienst, training of expert en zorgen ervoor dat u probleemloos aan de slag kunt. Gratis en voor niets. U kunt zorgeloos met uw software starten, wij zorgen ervoor dat u het meeste uit uw software kunt halen.

Loopt u tegen technische softwareproblemen aan? Dan kunt u gebruik maken van Cadac Support. Door de juiste informatie in te dienen kunnen wij u zo snel mogelijk helpen

Stel een vraag

Choose a region

Europe

World