1. Home
  2. Service & Support
  3. Support
  4. AutoCAD (LT)
  5. Troubleshooting
  6. Multiple drawings cannot be opened in AutoCAD

Multiple drawings cannot be opened in AutoCAD

Troubleshooting

Last modified on 25 July 2019

Problem:

Attempts to open multiple drawings within the same AutoCAD session fail, and the user is prompted to save the current drawing, prior to opening or creating any other drawing.


Causes:

This behavior occurs because the SDI system variable is not set to its default value, which is 0. The SDI (Single Document Interface) system variable is legacy, and is maintained within the program for backwards compatibility. SDI being set to 1 (or 3 in some cases) will enable the single-document mode, in which only one drawing is allowed to be open at a time.


This variable has largely been made obsolete, though, and no longer appears in AutoCAD's Options dialog nor the Help documentation. 


Solution:

To disable Single Document Interface:

  1. At the command prompt in AutoCAD, enter SDI.
  2. Enter 0 as the value.

The default value for SDI is 0. Some applications that were designed for earlier releases of the program may set the SDI system variable to a non-zero value for compatibility reasons.

SDI Settings

This list shows valid settings for SDI and explains what each setting does.

0Multiple drawing interface enabled
1Multiple drawing interface disabled
2Multiple drawing interface disabled by an application that does not support multiple drawings
3Multiple drawing interface disabled by user and by an application that does not support multiple drawings

Note: AutoCAD LT software only allows 0 or 1 for SDI because it cannot be used with add-on software. For AutoCAD products which are native to the Apple Macintosh (Mac) operating system (OSX), the SDI variable is set to 0, and is read-only. 



Source: https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Multiple-Design-Environment-MDE-does-not-function.html


At Cadac, we distinguish between Sales, Service & Support. We take Sales & Service for granted. We help you purchase your product, service, training or expert and make sure you can get started without any problems. Free of charge and for nothing. You can start using your software carefree, we make sure you can get the most out of it.

Are you running into technical software problems? Then you can use Cadac Support. By submitting the correct information, we can help you as quickly as possible.

Ask a question

What do you have a question about?

  • Support
  • Sales
  • Service
Log in to receive your personal prices

Log in to My Cadac

You are logged out

You have entered the wrong email address or password

New to Cadac Group?

  • The best prices Discover your personal price after creating an account
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support

Create an account

Your password must be at least 8 characters long, and include at least one lowercase letter, one uppercase letter, and a number.

You have left some fields blank or not completed them correctly

This email address is already in use.

Privacy statement

Why create an account?

  • The best prices The best prices
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support

Forgotten password

Having problems logging in? Enter your email address. You will then receive a link where you can reset your password. If you're not sure which email address was used, get in touch with us.

You have entered an invalid email address.

We do not have a record of this email address in our system.

Oops... An error occurred, please get in touch with us.

New to Cadac Group?

  • The best prices Discover your personal price after creating an account
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support

Forgotten password

You have been sent an email from us with a link to reset your password.

New to Cadac Group?

  • The best prices Discover your personal price after creating an account
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support

Reset password

Unfortunately, your link has expired or is invalid.
Click on the button below to request a new link.

Enter your new password below.

Your password must be at least 8 characters long, and include at least one lowercase letter, one uppercase letter, and a number.

Password only entered once or passwords do not match.

We do not have a record of this email address in our system.

Oops... An error occurred, please get in touch with us.

New to Cadac Group?

  • The best prices Discover your personal price after creating an account
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support

Password has been reset

Your password has been successfully changed. From now on, you will be able to log in with your new password.

New to Cadac Group?

  • The best prices Discover your personal price after creating an account
  • Buy or extend your Autodesk products Buy or extend your Autodesk products
  • Clear and easy to use webshop Clear and easy to use webshop
Need help? Service & Support